Acronis Storage: 'The Storage is not register with the user' error

Symptoms

1. You are trying to start Acronis Storage Gateway migration to Acronis Stroge 2.3 using the migration wizard.

2. Once you connect to Acronis Backup Cloud (step 3 of the wizard), the following error message appears:

The Storage at <address> is not register with the user <login> in https://cloud.acronis.com

Cause

After loging in with Acronis Backup Cloud credentials, Acronis Strorage migration wizard is trying to find the source Acronis Storage Gateway registration parameters in Acronis Backup Cloud. In this step, the migration wizard is using the address of Acronis Strorage Gateway provided in step 2 (Connect to source).

In case the provided address differs from the source storage that was registered in Acronis Backup Cloud, the wizard will not be able to find it. 

Solution

1. Open Acronis Backup Cloud management portal and note the source storage address (see the Name column)

2. Go back to step 2 of the migration wizard and specify exactly the same storage name of Acronis Storage Gateway which is registered in Acronis Backup Cloud.